Login   
C6owners :: Forums :: C6 Support :: The Garage

Version of DIAGBOX that works with C6 ?? v9.1 or 9.3

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Author Post
citroenroen1   
Thu May 09 2024, 03:53pm
Joined: Apr 18 2024
Member No: #5495
Location: Los Angeles
I am dealing with a UK seller who wants to sell me and send me DIAGBOX v9.1 or 9.3.
Does this version of DIAGBOX work with C6?

Your experiences and education over on that side of the pond are greatly appreciated.

C6Dave   
Thu May 09 2024, 05:41pm

Joined: Oct 01 2009
Member No: #1
Location: Northumberland
I would expect that it should be backward compatible, but it's worth asking the seller a specific question about it plus what operating system will it run on.

Looking at this online sale: - Click Here - then it does say:
wrote ...

latest DiagBox v9.178 (2024-01) you can also perform diagnostic work for Opel / Vauxhall 2020+ year models. You can do all as an authorized Dealer does. This diagnostics software allows you to perform complete diagnostics of all from 1995 till present models.

Operating systems: Windows 7 Pro, Windows 10 Pro 64bit

Though, not knowing what you are actually being offered makes it more difficult.

Looking at it, the operating system is the big plus with Diagbox v9. as IIRC, early versions ran win xp in 32 bit mode?

Hopefully someone can confirm for you shortly.
Website
citroenroen1   
Fri May 10 2024, 03:13am
Joined: Apr 18 2024
Member No: #5495
Location: Los Angeles
I want this for my C6 ONLY ....
(none of these other newer vehicles exist / were sold in USA) .
So will this newer software work correctly with the 2006 C6?
onthecut   
Fri May 10 2024, 10:49am
Joined: Sep 20 2016
Member No: #2793
Location: West Mids
My understanding is that versions after about 7.2 are much more aligned to the current range of vehicles and the need to log on to the PSA server for many processes.

I acquired 7.2 for my C4 --- I will try it on the C6 whenI have a chance and see how it reacts. I don't know about the later versions, but be aware some versions have to be loaded incrementally.

Mike.
Trainman   
Wed Jun 05 2024, 11:38am

Joined: Apr 12 2010
Member No: #86
Location: Penwortham
I find the newer versions of Lexia/Diagbox to be less useful, as some of the functionality has been removed, I have Lexia 5.** which suffices for the bits I need it to, its not perfect, but it works for most things.
cruiserphil   
Fri Jun 07 2024, 11:44am

Joined: Jan 24 2010
Member No: #38
Location: Celbridge
Hello Citroenroen1,

I operate on Diagbox 7.44 and haven't updated since then with no issues. Version 7.1 or 7.2 would probably be enough!

Best regards,

Phil C.
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, C6 owner, Technical Expert, C6 Premier Discount Club