Login   
C6owners :: Forums :: C6 Support :: The Garage

abs,esp,handbrake error help anyone

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
ststech   
Tue Aug 11 2015, 06:28pm
Joined: Aug 31 2014
Member No: #1845
Location: CREWKERNE somerset
Hi i have just fitted a replacement handbrake motor unit,
It works ok it applies and releases ok,
My problem is that the abs and esp lights come on due to lexia reporting a faulty rear left speed sensor, this also is the only fault that shows up under secondary brake.

If you wait about a minute or so it then comes up handbrake faulty and a little yellow warning triangle comes up yet handbrake still operates fine, Switch ignition off and back on and abs followed by esp asr then a minute later the little yellow triangle.

i used lexia to initialsie the handbrake and tension the cables which came back ok.

I have 2 new rear abs sensors ready to fit when i have the rear wheel bearings replaced, I was wondering if the abs fault would flag up a handbrake fault, Iknow my last c6 had similar problems with abs sensors and irc it giving handbrake errors but am not sure.
Website
cruiserphil   
Tue Aug 11 2015, 06:40pm

Joined: Jan 24 2010
Member No: #38
Location: Celbridge
Hello St,

The electric handbrake relies on speed information from the ABS system so if you have a faulty ABS sensor you will also get the handbrake error.

Best regards,

Phil C.
1 User said Thank You to cruiserphil for this Post :
 ststech (11 August 2015)
ststech   
Tue Aug 11 2015, 07:14pm
Joined: Aug 31 2014
Member No: #1845
Location: CREWKERNE somerset
Thanks for clarifying that PhiL

Irc similar with my last c6 but wasnt sure,
Well she going in for rear wheel bearings so going to replace both rear wheel speed senors at same time, Even though offside rear is ok more of a preventative measure really.
Website
1 User said Thank You to ststech for this Post :
 cruiserphil (11 August 2015)
ststech   
Tue Aug 11 2015, 10:45pm
Joined: Aug 31 2014
Member No: #1845
Location: CREWKERNE somerset
update

This c6 has been very badly abused
the problem i mentioned above has another part to it,

the other half drove it to town earlier applied handbrake and when she got back in car and tried to release it the handbrake wouldnt release,
she said she had to switch off then back on and try again it released but she said it was dragging?

this fault was what happened to previous owner he applied handbrake and it would not release, so it was recovered where his mechanic cut one of the handbrake cables
hence me having to buy another handbrake unit,

So i went and tried the car just now applied and released handbrake a few times all ok then applied it and it wouldnt release so i switched off and on stil wouldnt release did it again and it did,
the other problem i noticed when i parked up the gear lock solenoid was playing up, it meant you could select any gear without pressing footbrake?? and only engaged when ignition switched off everytime you switched ign on or off you could here it disengage allowing gear selection without applying footbrake then displayed put automatic gearbox in park and bleeped,
So i left it for a while then switched ign on and kept pressing brake pedal you could hear the gear lock engage disengage,

i know lexia has reported

State of the ECU: SID201
Reference 1 : 644384
Reference 2 :
Faults present : 1

P1536 : brake contact signal
Characterisation : Switch not functional
Status : Permanent fault
Location : local .
Variables associated with the fault
Engine speed : 0 rpm
engine torque : 0
engine coolant temperature : 47 °C
battery voltage : 12 Volt(s)
engine status : 01
time elapsed since ignition positive : 336 s
supply voltage of sensors : 5.018 V
supply voltage of sensors : 5.018 V
ECU load : 31 %
injector voltage : 58.94 V
+ ignition on voltage : 11 V


could a faulty brake switch be the cause of the above problems ??
Website
cruiserphil   
Wed Aug 12 2015, 08:03am

Joined: Jan 24 2010
Member No: #38
Location: Celbridge
Hello St,

Yes. We had the same problem with the brake pedal switch. The gear selector will release when the ABS fault appears. Also the handbrake may not release. If this happens tap the brake pedal rapidly and it might clear. Otherwise my wife discovered that when the handbrake won't release, put the car in reverse and apply a little power and release the handbrake. This works every time but strangely will not work in forward. This is how we coped until I replaced the switch.

The switch is not expensive and very easy to change. Just make sure to fit the extension loom that comes with it.

Best regards,

Phil C.
C6Dave   
Wed Aug 12 2015, 08:19am

Joined: Oct 01 2009
Member No: #1
Location: Northumberland
P1536 relates to the brake pedal switch and it's harness. It's a well documented problem across the C6 and C4 range so start by replacing it as it's only circa £34 to buy.


Website
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, C6 owner, Technical Expert, C6 Premier Discount Club