Login   
C6owners :: Forums :: C6 Support :: The Garage

Coolant leak problem?

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
Radox   
Sat Nov 16 2019, 12:38pm
Joined: Aug 27 2019
Member No: #4044
Location: Bad Bergzabern
Hi, in the last 3-4 months, I have noticed that about once per week, my coolant reservoir has white leaks on the outside. I wipe them clean, but in several days they are back. What could be the problem?

Today I bought a new original coolant reservoir cap from the Citroen dealer and will change it later. Probably the old cap's valve is broken somehow? And one more question? The new cap look a little bit different than the old one. Is that a problem or they have simply changed the design in the last 12 years?

C6Dave   
Sat Nov 16 2019, 12:57pm

Joined: Oct 01 2009
Member No: #1
Location: Northumberland
You can still get an original style cap but doubt it makes any difference, just the look.

'White' spots are likely to be dried coolant, my radiator etc. was covered in it when it leaked.
Website
Radox   
Sat Nov 16 2019, 01:25pm
Joined: Aug 27 2019
Member No: #4044
Location: Bad Bergzabern
C6Dave wrote ...

You can still get an original style cap but doubt it makes any difference, just the look.

'White' spots are likely to be dried coolant, my radiator etc. was covered in it when it leaked.


Yes, I know it's a dried coolant, but it seems to be leaking from the cap. That's why I hope the problem was the cap itself, and not something more serious
Tjensen   
Sat Nov 16 2019, 07:13pm
Joined: Jul 17 2012
Member No: #954
Location: Bergen
If the system is a bit overfilled, the cap will let some coolant out when the engine is hot. Happened to me several times, but I dont think I have any leaks or problems.
Radox   
Fri Dec 06 2019, 07:56pm
Joined: Aug 27 2019
Member No: #4044
Location: Bad Bergzabern
It's me again with a small question. I changed the cap and this solved the white leakage problem. After installing the new cap, I filled the cooland to the max. However today, 3 weeks later, I checked the coolant (on a cold motor) and it is about half an inch below max. Is this loss normal, or do I have another problem?
Tjensen   
Fri Dec 06 2019, 09:26pm
Joined: Jul 17 2012
Member No: #954
Location: Bergen
I have the same experience. Filling to the max and after a while a few cm under the max mark, and stays there. I have stopped worrying.
MGmike   
Sat Dec 07 2019, 09:27am
Joined: May 21 2017
Member No: #3151
Location: South Queensferry
Radox wrote ...

It's me again with a small question. I changed the cap and this solved the white leakage problem. After installing the new cap, I filled the cooland to the max. However today, 3 weeks later, I checked the coolant (on a cold motor) and it is about half an inch below max. Is this loss normal, or do I have another problem?


Check the level in the tank when the engine is hot (without taking the cap off!). It should be above the max and probably right up to the cap as a result of the heat expansion. If it is, it suggests the cap is slightly below the expected pressure relief specification. As Tjensson says, its not a problem if the level stays above the min mark on the tank but you might prefer to take it back to the dealer and try another one.
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, C6 owner, Technical Expert, C6 Premier Discount Club