Login   
C6owners :: Forums :: C6 Support :: The Garage

3.0HDI Webasto parking heater installation

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
Zlin   
Wed Aug 14 2019, 03:47pm
Joined: Nov 18 2013
Member No: #1496
Location: Rackeve
Dear All,

I've just installed a Webasto parking heater (Thermo Top Evo 5) for my 3.0HDI. Itself the heater is working very well, but I have problem with the control of the cabin fan. The fan should be controlled by the BSI. A switched ground signal is required to the pin 6 of the 40VNR connector of BSI according to the wiring diagram (both original Citro├źn's and webasto manual). This signal is sent to the BSI when a controlled relay switching it, but the fan does not start to operate. The BSI configuration setting changed to "parking heater" as well.
Could you please help me what may the problem?

Thank you in advance!
joopajaa   
Sat Aug 24 2019, 09:43am
Joined: Sep 06 2017
Member No: #3261
Location: Byroslavia, FIN
Not sure if its 100% same on 2.7 but I did it manually (as old C5 webasto instructions tolds): add 3 relays and +12V line from battery to fan cable connector (on LH front foot well, one small is to behind ac control-panel to cut CAN from the panel when car is not running (letting the fan to work).

Other relays are needed to control the fan (under bonnet, in ECU box to fan), the other cuts the webasto +12V line when car is running etc..

No need for costly PWM-relays from webasto IMHO.
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, C6 owner, Technical Expert, C6 Premier Discount Club