Login   
C6owners :: Forums :: C6 Support :: The Garage

Occasional RPM "Flare"

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
mister_iainm   
Wed Jul 10 2019, 10:27am
Joined: Aug 28 2017
Member No: #3253
Location: Melrose
So... 'tis the summer, and the traditional time (along with spring, autumn and winter) for my C6 to test my resolve, my ticker and my wallet with new and interesting "did it, didn't it?" potential failure modes.

Twice in the last couple of weeks, I've felt/seen/heard the RPM flare to around 3K when exiting a junction, for no apparent reason.

I can't reproduce this "on demand".

Any thoughts anyone? I have not [yet] changed the ATF, so I did wonder if this was an early indication of oil breakdown?

Iain M
joopajaa   
Fri Jul 12 2019, 05:24am
Joined: Sep 06 2017
Member No: #3261
Location: Byroslavia, FIN
Could be atf issue, I would do a flush service before its too late. Mine havent had such issue yet - I have changed the 3L portion twice and should do it once or twice more. I believe that is "gentle" service model suitable for us DIY'ers but it has to be done before any issues will arise I think.
1 User said Thank You to joopajaa for this Post :
 cruiserphil (15 July 2019)
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, C6 owner, Technical Expert, C6 Premier Discount Club