Login   
C6owners :: Forums :: C6 Support :: The Garage

Passenger's side blown air temperature

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Author Post
Phoenix   
Mon Jun 17 2024, 05:13pm
Joined: Apr 14 2019
Member No: #3891
Location: Macedonia
Greetings everyone!
I've been an owner (and also a member of this forum) of a lovely 2.2 C6 (2007) for 5 years.

Few days ago the A/C suddenly stopped blowing cold air on passenger side. Also the rear compartment blower hasn't been working properly for a long time (the blower is not turning on most of the time). I checked the A/C status trough Diagbox and the flaps motors are working properly, showing no errors. The only unusual component is the passenger side's blown air temperature which is showing -34,8 C.

There are few topics on the forum which have discussed this issue, but all of them hint toward broken flaps. I don't think this is the issue in my case because, when set at low temperature, the passenger side is blowing "normal" interior or exterior air, but when I set it to high temperature it starts blowing heated, hot air.

Can somebody pinpoint the location of the faulty sensor, or maybe hint towards a different solution?
MGmike   
Mon Jun 17 2024, 06:33pm

Joined: May 21 2017
Member No: #3151
Location: South Queensferry
The temperature sensor is on the side of the unit. If you're lucky you'll be able to get to it from below the glovebox otherwise you'll need to remove it.
Phoenix   
Mon Jun 17 2024, 06:47pm
Joined: Apr 14 2019
Member No: #3891
Location: Macedonia
MGmike wrote ...

The temperature sensor is on the side of the unit. If you're lucky you'll be able to get to it from below the glovebox otherwise you'll need to remove it.

Thank you for answer. I presume the sensor product code is 6445VC, correct?

MGmike   
Tue Jun 18 2024, 07:54pm

Joined: May 21 2017
Member No: #3151
Location: South Queensferry
yep, that's the one.
Phoenix   
Wed Jun 19 2024, 07:38pm
Joined: Apr 14 2019
Member No: #3891
Location: Macedonia
MGmike wrote ...

yep, that's the one.
Unfortunately after removing the glovebox I wasn't able to find the sensor, only the flaps motors were visible. After checking next to the pedals I was able to find what I recon to be the 6445 TZ sensor, but not the VC sensor.





Mine is a LHD maybe in your comment you were referring to a RHD model?
raboten9   
Fri Jul 12 2024, 05:55pm
Joined: Jul 28 2018
Member No: #3609
Location: Varna
It's here!

raboten9   
Fri Jul 12 2024, 06:09pm
Joined: Jul 28 2018
Member No: #3609
Location: Varna
I'm also due to replace the sensor and am currently looking for a way to replace it without removing the center console.

If you managed to change it, could you explain how you achieved it?
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, C6 owner, Technical Expert, C6 Premier Discount Club