Login   
C6owners :: Forums :: C6 Support :: The Garage

GPS started acting up after a car wash

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
Paulius   
Sat Jun 29 2019, 08:49am
Joined: Aug 14 2014
Member No: #1821
Location: Vilnius
I have recently noticed that my RT4 GPS doesn't work properly anymore. It sticks to a location that is quite close (or point-on, actually), but it does not move along as you drive, only rotates the map around the 'stuck' point.
GPS Satellites Available number shows 10 satellites one moment and 5 sattelites another. And it keeps changing every few seconds.

Tried resetting the system by holding down DARK button, but it does not help at all.

Where is the GPS antenna located? I suspect that, during a car wash, some water could have gone in there that keeps it from working properly. Maybe there is a way to dry it?

Sincere thanks for any advice.
Paulius   
Sat Jun 29 2019, 12:03pm
Joined: Aug 14 2014
Member No: #1821
Location: Vilnius
Found the antenna, seems dry and the wiring also looks ok. And now it finds 6 sattelites at most. Could it be that the headunit itself's gone bad?
Paulius   
Thu Jul 25 2019, 08:21pm
Joined: Aug 14 2014
Member No: #1821
Location: Vilnius
An update - after replacing a faulty REAR-LEFT ABS sensor the satnav started operating normally again. Apparantly it needs to know the speed of the vehicle. What's also apparent is that it uses the rear left wheel for that measurement for some reason.
4 User said Thank You to Paulius for this Post :
 C6Dave (26 July 2019) , MarkBevan (26 July 2019) , 321dave (26 July 2019) , cruiserphil (29 July 2019)
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, C6 owner, Technical Expert, C6 Premier Discount Club