Login   
C6owners :: Forums :: C6 Support :: 3.0 HDi Forum

Engine Coolant Sensor Refit per Vaho

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
cruiserphil   
Tue Mar 05 2019, 09:17pm

Joined: Jan 24 2010
Member No: #38
Location: Celbridge
Having installed the coolant sensor in the 2.7Hdi, I started looking at fitting the 3.0HDi. I believe connections are there in the engine fusebox but unfortunately I cannot find an engine coolant sensor (missing/present) option in the BSI menu on Diagbox or Lexia. I compared BSI part numbers on both cars and they are different - 9654425680 (2.7HDi) v. 9664058780 (3.0HDi). The software version on the 2.7HDi is 09.84 and on the 3.0HDi is 8.22. It looks like the only hope is to pick up a different unused BSI input if there is one? But I'm open to other ideas from those who know more about BSI matters.

Best regards

Phil C.
Nikola   
Thu Feb 04 2021, 07:02pm
Joined: Aug 03 2018
Member No: #3613
Location: Beograd
So did you find way
1 User said Thank You to Nikola for this Post :
 cruiserphil (05 February 2021)
cruiserphil   
Fri Feb 05 2021, 10:03am

Joined: Jan 24 2010
Member No: #38
Location: Celbridge
Hello Nikola,

I did not follow up. Member Sstech suggested that he could add the low coolant warning option to the BSI. I would have to send him the BSI. I need to start thinking about it again.

Best regards,

Phil C.
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, C6 owner, Technical Expert, C6 Premier Discount Club