Login   
C6owners :: Forums :: C6 Support :: Car Care and Maintenance Tips

Electric handbrake not releasing, SOLVED

Home   Forum Rules    Forum Help  Conversion Tools
   
Please Register to enjoy additional Member Benefits
Top Thanked Forum Posts: Today | Week | Month | Year | All time | Most Thanks Given: To member | By user
Author Post
jannelehtimaki   
Wed Aug 09 2017, 05:45pm
Joined: Jul 24 2013
Member No: #1374
Location: Finland
I have struggled some time with handbrake not releasing properly on one side.

Finally the solution was very simple and cheap. There is a handbrake cable suspender (see picture) on each side, but on the problematic side it was broken.

This suspender does not seem to be important but it really is. With a broken suspender the cable make an angle at the wheel end, and the return spring cannot overcome the friction caused by the angle.

I just replaced the suspender with something else (hose clamp/cable tie......) when the cable is in right position =no angle at the rear end, -everything works fine.

I hope this help someone, Br Janne

9 User said Thank You to jannelehtimaki for this Post :
 TonyK (09 August 2017) , C6Dave (09 August 2017) , Hattershaun (09 August 2017) , e3steve (09 August 2017) , MarkBevan (10 August 2017) , Cisco (10 August 2017) , cruiserphil (11 August 2017) , josok (12 August 2017) , xantiaboy (05 January 2020)
YankeeC6   
Tue Feb 11 2020, 10:40am
Joined: Jan 31 2020
Member No: #4242
Location: Kaiserstra├če
Thank you for that post... can you please describe where this defective part is located?
C6Dave   
Tue Feb 11 2020, 12:47pm

Joined: Oct 01 2009
Member No: #1
Location: Northumberland
@YankeeC6 Looking at the parts guide (7) there going to be near the rear wheels..

Website
 

Jump:     Back to top

User Colour Key:
Head Administrator, Administrator, C6 owner, Technical Expert, C6 Premier Discount Club